My petcock threw up—!

Vermont4me

XS400 Member
Messages
21
Reaction score
2
Points
3
Location
Hartford, CT
Help please- my 81 xs400 is almost ready for new life- rebuilt carbs, reinstall fuel lines, vacuum line and boom, my petcock is leaking fuel- my bike hasn’t seen oil or car for 30 years so pretty sure the petcock seals are shot- is there an aftermarket petcock anyone can recommend that I can grab fairly quickly?

thx-
Bob
 
I put a purely mechanical one on my 78 off Amazon. I just posted the link in another thread, I'll see if I can find it.
 
Thank you- being that my vacuum system still works (I think) will it interfere with the operation of the bike that you know if? Cheers
 
When you say ‘switched it’ you mean petcock right? Thx so much btw- it’s a huge help- looking forward to getting my 81 (3300 miles) ON THE ROAD!!
 

Attachments

  • 1CD18D3D-6381-488E-A2EB-3AE867A42D62.jpeg
    1CD18D3D-6381-488E-A2EB-3AE867A42D62.jpeg
    320.4 KB · Views: 85
If I can ask one final question (mechanic I’m not…) so when I install the new petcock, I simply cap the vacuum nipple that previously had a hose on it to the petcock? Thx
 
If I can ask one final question (mechanic I’m not…) so when I install the new petcock, I simply cap the vacuum nipple that previously had a hose on it to the petcock?

Yes. Install the manual petcock and make sure that both of the vacuum nipples on the carb holders are capped off.
 
Wow, what a journey, I (hope) that I’m almost there- new petcock arrived, installed it along with the new-old carbs, gassed it, sprayed the carb cleaner and it FIRED up after 32 years of sitting in a barn (oil is decent etc-) PROBLEM- the right muffler (which was heat colored when I got it..) appears to heat up and actually smoked a bit- have to adjust the idle speed tomorrow but the muffler smirking has me worried (btw, I ‘capped’ the vacuum nipples…) any ideas? Thanks so much!
 
Ok my friend, for some reason I feel that you’ve ‘been there’ for this cycle rehab- new wrinkle, bike was running odd (mentioned the gas leak etc) so I removed the carbs (again, and btw, they were originals from eBay in seemingly good shape..)- upon closer examination the float was corroded right thru- question, is there a pair of new aftermarket carbs that you’d recommend I can snag to get this baby running again-
 

Attachments

  • D8859027-B4F8-4ADD-A14F-A8F448437CAC.jpeg
    D8859027-B4F8-4ADD-A14F-A8F448437CAC.jpeg
    238 KB · Views: 77
I second the attempt to source some new(ish) floats for the original BS34 carbs. Other carbs will work, but you will have to be ready to spend a lot of time learning by trial and error to get them dialed in. The flat slides from Mikuni and Keihin are good choices, and there are a bunch of racers who use these on similar displacement bikes, but having carbs that Yamaha engineers already figured out is worth something.
 
Appreciate your time, you have been wicked helpful- so yesterday, yeah, got the bike running and idling smooth but fuel kept rolling out of one side- i even ride the bike, felt good…took the carbs off, then apart and cleaned them, thinking maybe the initial ‘starting’ got em bunked up- put em back together and reinstalled them and didn’t even notice the hole in the float- took them back out and then I noticed- anyway, the seller from eBay was understanding and I really do feel it was an oversight so I found another set, ordered two rebuild kits and had to put off what I wanted to happen yesterday-:) lol-
 
Back
Top