DOHC Seca no power after 4000 rpm

GMO

XS400 New Member
Messages
4
Reaction score
1
Points
1
Location
Belgium
Hello everyone,

In the past I had a faulty TCI. I replaced the module with one I found for 45 euros. The bike started like a charm, but from that moment the bikes power after 4000 rpm was awefully low. At the time I suspected a carb related issue and got to work.

I recently cleaned my carbs using an ultrasonic cleaner and blasted all the holes I could find with carb cleaner. I then inspected and cleaned the parts such as neeldes, float, jets,...
After reinstalling the carb body on the bike, it starts smoothly. Unfortunately the bike still loses its power at 4000 rpm and acceleration is very poorly. I yet have to check float height nevertheless.

Could this problem still be carb related or do you guys think it is the TCI?

Thanks for your help.
 
Does it do better or worse when adding enrichener? If better, then the engine is leaning out- some kind of fuel starvation relative to the air. If worse, then too much fuel. Probably worth making sure you don't have a vacuum leaks; with engine running spray wd40 around the various carb sealing surfaces- checking for change in engine. if it does, you just found a vacuum leak.

Carb bowls going empty could be possible, but I'd go for eliminating other causes first. If they are going empty then I'd guess that the enrichener will make no difference.
 
Probably worth making sure you don't have a vacuum leaks; with engine running spray wd40 around the various carb sealing surfaces- checking for change in engine. if it does, you just found a vacuum leak.

As suggested - definitely check for leaks first.

A couple of other thoughts:
Make sure your timing is set with a timing light on the left plug lead and aiming at the timing inspection window (you should see the "LF" mark at idle). Also, have a friend roll on the throttle and make sure the timing is advancing properly (you will see the advance marks move into the window). The TCI should advance the timing to between 36 to 40 degrees BTDC at about 3000rpm (there are marks at 30, 35, and 40 degrees BTDC on the flywheel you can look for). If the TCI doesn't advance the spark, you will not have good power.

Mid-range fuel response is controlled mostly by the needle jet and jet needle in the carbs. If someone messed with them by blindly changing them with ones from a generic rebuild kit, that can cause this issue. A word to the wise - never use the jets from a generic rebuild kit. Throw those out and clean and reuse the genuine Mikuni stuff.
 
Back
Top